equal
deleted
inserted
replaced
|
1 #!/bin/sh |
|
2 |
|
3 set -e |
|
4 set -x |
|
5 |
|
6 ### Setup tests |
|
7 |
|
8 # Uncomment if tests require database access |
|
9 #service postgresql restart || service postgresql start |
|
10 #trap 'service postgresql stop' EXIT |
|
11 |
|
12 cp -r test tox.ini "$AUTOPKGTEST_TMP" |
|
13 chown -R nobody:nogroup "$AUTOPKGTEST_TMP" |
|
14 |
|
15 ### Run tests |
|
16 |
|
17 for py in $(py3versions -r 2>/dev/null); do |
|
18 cd "$AUTOPKGTEST_TMP" |
|
19 echo "Testing with $py:" |
|
20 su nobody --shell /bin/sh \ |
|
21 -c "$py -m pytest -v" |
|
22 done |