skeleton/debian/rules.tmpl
changeset 5334 7da1a6ca8f65
parent 1667 145af5f29f12
child 8098 e80edd022901
equal deleted inserted replaced
5333:9eea4a5eaf1a 5334:7da1a6ca8f65
     5 # Uncomment this to turn on verbose mode.
     5 # Uncomment this to turn on verbose mode.
     6 #export DH_VERBOSE=1
     6 #export DH_VERBOSE=1
     7 build: build-stamp
     7 build: build-stamp
     8 build-stamp:
     8 build-stamp:
     9 	dh_testdir
     9 	dh_testdir
    10 	python setup.py -q build
    10 	NO_SETUPTOOLS=1 python setup.py -q build
    11 	touch build-stamp
    11 	touch build-stamp
    12 
    12 
    13 clean:
    13 clean:
    14 	dh_testdir
    14 	dh_testdir
    15 	dh_testroot
    15 	dh_testroot
    21 install: build
    21 install: build
    22 	dh_testdir
    22 	dh_testdir
    23 	dh_testroot
    23 	dh_testroot
    24 	dh_clean -k
    24 	dh_clean -k
    25 	dh_installdirs -i
    25 	dh_installdirs -i
    26 	python setup.py -q install --no-compile --prefix=debian/%(distname)s/usr/
    26 	NO_SETUPTOOLS=1 python setup.py -q install --no-compile --prefix=debian/%(distname)s/usr/
    27 	# remove generated .egg-info file
    27 	# remove generated .egg-info file
    28 	rm -rf debian/%(distname)s/usr/lib/python*
    28 	rm -rf debian/%(distname)s/usr/lib/python*
    29 
    29 
    30 
    30 
    31 # Build architecture-independent files here.
    31 # Build architecture-independent files here.