debian/rules
branchstable
changeset 8648 67a5fccb802a
parent 8647 2294fad830ca
child 9174 959dbad7743e
equal deleted inserted replaced
8647:2294fad830ca 8648:67a5fccb802a
    16 	ln -sf $(CURDIR) debian/pythonpath/cubicweb
    16 	ln -sf $(CURDIR) debian/pythonpath/cubicweb
    17 	# documentation build is now made optional since it can break for old
    17 	# documentation build is now made optional since it can break for old
    18 	# distributions and we don't want to block a new release of Cubicweb
    18 	# distributions and we don't want to block a new release of Cubicweb
    19 	# because of documentation issues.
    19 	# because of documentation issues.
    20 	-PYTHONPATH=$${PYTHONPATH:+$${PYTHONPATH}:}$(CURDIR)/debian/pythonpath $(MAKE) -C doc/book/en all
    20 	-PYTHONPATH=$${PYTHONPATH:+$${PYTHONPATH}:}$(CURDIR)/debian/pythonpath $(MAKE) -C doc/book/en all
       
    21 	# squeeze has a broken combination of jquery and sphinx, fix it up so search works(ish)
       
    22 	if grep -q jQuery\\.className doc/html/_static/doctools.js && grep -q "jQuery JavaScript Library v1\.4\." doc/html/_static/jquery.js; then \
       
    23 	    echo 'Patching doctools.js for jQuery 1.4 compat'; \
       
    24 	    sed -i 's/jQuery\.className.has(node\.parentNode, className)/jQuery(node.parentNode).hasClass(className)/' doc/html/_static/doctools.js; \
       
    25 	fi
    21 	rm -rf debian/pythonpath
    26 	rm -rf debian/pythonpath
    22 	touch build-stamp
    27 	touch build-stamp
    23 
    28 
    24 clean:
    29 clean:
    25 	dh_testdir
    30 	dh_testdir