cubicweb.spec
branchstable
changeset 8873 280c32415059
child 8875 a2b4f245aa57
equal deleted inserted replaced
8872:b638a99ab9cf 8873:280c32415059
       
     1 %if 0%{?el5}
       
     2 %define python python26
       
     3 %define __python /usr/bin/python2.6
       
     4 %else
       
     5 %define python python
       
     6 %define __python /usr/bin/python
       
     7 %endif
       
     8 
       
     9 Name:           cubicweb
       
    10 Version:        3.16.1
       
    11 Release:        logilab.1%{?dist}
       
    12 Summary:        CubicWeb is a semantic web application framework
       
    13 Source0:        http://download.logilab.org/pub/cubicweb/cubicweb-%{version}.tar.gz
       
    14 License:        LGPLv2+
       
    15 Group:          Development/Languages/Python
       
    16 Vendor:         Logilab <contact@logilab.fr>
       
    17 Url:            http://www.cubicweb.org/project/cubicweb
       
    18 
       
    19 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
       
    20 BuildArch:      noarch
       
    21 
       
    22 Requires:       %{python}
       
    23 Requires:       %{python}-logilab-common >= 0.59.0
       
    24 Requires:       %{python}-logilab-mtconverter >= 0.8.0
       
    25 Requires:       %{python}-rql >= 0.31.2
       
    26 Requires:       %{python}-yams >= 0.36.0
       
    27 Requires:       %{python}-logilab-database >= 1.9.0
       
    28 Requires:       %{python}-passlib
       
    29 Requires:       %{python}-lxml
       
    30 Requires:       %{python}-twisted-web
       
    31 # the schema view uses `dot'; at least on el5, png output requires graphviz-gd
       
    32 Requires:       graphviz-gd
       
    33 Requires:       gettext
       
    34 
       
    35 BuildRequires:  %{python}
       
    36 
       
    37 %description
       
    38 a repository of entities / relations for knowledge management
       
    39 
       
    40 %prep
       
    41 %setup -q
       
    42 %if 0%{?el5}
       
    43 # change the python version in shebangs
       
    44 find . -name '*.py' -type f -print0 |  xargs -0 sed -i '1,3s;^#!.*python.*$;#! /usr/bin/python2.6;'
       
    45 %endif
       
    46 
       
    47 %install
       
    48 NO_SETUPTOOLS=1 %{__python} setup.py --quiet install --no-compile --prefix=%{_prefix} --root="$RPM_BUILD_ROOT"
       
    49 
       
    50 %clean
       
    51 rm -rf $RPM_BUILD_ROOT
       
    52 
       
    53 %files 
       
    54 %defattr(-, root, root)
       
    55 /*
       
    56