debian/rules
branchstable
changeset 7767 07c74f5585d1
parent 7512 d2de5fb0cc33
child 8476 864a92b10cb8
equal deleted inserted replaced
7766:a832677c0aa6 7767:07c74f5585d1
     8 PY_VERSION:=$(shell pyversions -d)
     8 PY_VERSION:=$(shell pyversions -d)
     9 
     9 
    10 build: build-stamp
    10 build: build-stamp
    11 build-stamp:
    11 build-stamp:
    12 	dh_testdir
    12 	dh_testdir
    13 	# XXX doesn't work if logilab-doctools, logilab-xml are not in build depends
       
    14 	# and I can't get pbuilder find them in its chroot :(
       
    15 	# cd doc && make
       
    16 	# FIXME cleanup and use sphinx-build as build-depends ?
       
    17 	NO_SETUPTOOLS=1 python setup.py build
    13 	NO_SETUPTOOLS=1 python setup.py build
    18 	# XXX uncomment this and associated build-depends in control
    14 	# documentation build is now made optional since it can break for old
    19 	#when necessary sphinx version is in all built distribution
    15 	# distributions and we don't want to block a new release of Cubicweb
    20 	#PYTHONPATH=$(CURDIR)/.. $(MAKE) -C doc/book/en all
    16 	# because of documentation issues.
       
    17 	-PYTHONPATH=$(CURDIR)/.. $(MAKE) -C doc/book/en all
    21 	touch build-stamp
    18 	touch build-stamp
    22 
    19 
    23 clean:
    20 clean:
    24 	dh_testdir
    21 	dh_testdir
    25 	dh_testroot
    22 	dh_testroot
    71 	dh_installlogrotate -i
    68 	dh_installlogrotate -i
    72 	dh_installdocs -i -A README
    69 	dh_installdocs -i -A README
    73 	dh_installman -i
    70 	dh_installman -i
    74 	dh_installchangelogs -i
    71 	dh_installchangelogs -i
    75 	dh_link -i
    72 	dh_link -i
    76 	dh_compress -i -X.py -X.ini -X.xml
    73 	dh_compress -i -X.py -X.ini -X.xml -X.js -X.rst
    77 	dh_fixperms -i
    74 	dh_fixperms -i
    78 	dh_installdeb -i
    75 	dh_installdeb -i
    79 	dh_gencontrol  -i
    76 	dh_gencontrol  -i
    80 	dh_md5sums -i
    77 	dh_md5sums -i
    81 	dh_builddeb -i
    78 	dh_builddeb -i